Get in touch
Back
Downtime

Server delay

Started 18 Jun at 12:11pm CEST, resolved 18 Jun at 12:16pm CEST.

Server 1 (Prod1)
Resolved

We are back again. Sorry again for the delay!

Posted 18 Jun at 12:16pm CEST.
Created

We are currently experiencing delays on our servers. Apologies for the inconvenience and we are currently trying to scale up.

Posted 18 Jun at 12:11pm CEST.